Can't connect to Web - UI

Alright, so I installed MineOS on virtualbox, and I looked up a few tutorials just in case I was configuring something wrong. I made sure and set my network to bridged.

For whatever reason, I am unable to connect to the Web-UI using the ip and port it gives. It just keeps coming up as this webpage is not available. I am trying to access it through Chrome on the same machine that is running virtualbox. I also tried accessing it through Microsoft Edge … and it also didn’t go through either.

I used the command ifconfig, and it does show that it has an IP, and the ip is also appearing as active on my router. I tried turning off all firewalls too, just to make sure it wasn’t an issue with that.

Much help would be greatly appreciated.

Edit: I should mention it was able to access the internet and download updates just fine.

What is the exact address you’re typing in your browser? (and please, do not change out the IP or anything–it is not a security hazard to provide this information)

No worries, I know it’s not.
The IP I am using is

Also, since I am fairly new to this, I did try a couple of other things, just to be sure. Such as trying localhost, and I also checked my hosts file to make sure there wasn’t anything in there blocking it.

Really, I am at a loss … I can’t figure out what I am doing wrong.

Most browsers will turn that IP in to

The address you want it, explicitly saying HTTPS and 8443 (otherwise would default to 443)

Yep … already tried that. Didn’t seem to make any difference at all. I tried, http://, https://, with and with out the port number. All came back as unable to connect.

Did you install the Turnkey ISO or did you install it atop a different distribution?

Also, you needn’t try additional variations. There’s one string that will work, and it’s HTTPS with the port number.

I installed the ISO, since I figured it be easier that way.

In the VM command line, if you type top do you see the node instance running?

have you changed anything other than simply installing it? I mean, this is the ISO that is responsible for over half of MineOS installs, so there’s gotta be something…

Such as, did you update the git repo manually? Have you been trying to import a server via SFTP? Anything outside of the install process?

Yes, the node instance is running

Also no, it’s a fresh install with absolutely no changes at all.

Can you ping the MineOS guest?

Not exactly sure how you go about doing that. Is there a specific command I need to use?

from your desktop: ping

Nope, am unable to ping it. I just get request time outs.

I think then, it’s a VM connectivity issue, check your networking settings in Virtualbox again.

You set it to bridged…did you do a static IP or DHCP?

It’s definitely set to bridged, and I have tried both static IP and DHCP.

Edit: Ok so, I was able to get it working sort of. I created a bridge between my network adapter with the Virtual box host-only network. When I used this bridge as the bridge on the VM, I am able to access the web ui. However, I am unable to ping it still, and can’t access it through sftp.

Also … the connection doesn’t seem to be appearing on my router. So it sounds like doing it this way makes the connection entirely local or something like that.

But maybe it might give a clue to as what the problem is.

can u help me i think i have the same issue i cant see it in chrome but i can ssh to it thru
i can ssh using this thing root@ and then the port 22
i cant use the ip on google chrome IP:
it comes up with a page saying this website is not working
thanks cads181


Can you confirm the webui is up?

Hello hexparrot, i am searching for months right now just to see answers for my problem and i cant see the node instant running. Can you help me =). Im CreeperHaed from Germany and would be happy if you could…

Please make your own thread instead of resurrecting one.