Cannot connect to WebUI

I’m completely new to linux with absolutely no experience in it so please dumb it down for me. I’ve installed MineOS on my laptop (Dell Latitude C600, 1GHz Pentium 3 256mb ram if it matters) and I think it’s working, I can connect to the :12320 and :12321 things but I can’t connect to the WebUI. I’m entering it as but it always says that it can’t connect.

HTTPS? Be sure to put that specifically in, because it’s required.

Let me know if that is the issue at hand or we can look further into it.

I’m entering the https:// too, but it doesn’t work.

Try the instruction here to see if the webui is running:

How do I enter all that stuff?

The command line terminal, or via ssh

When I do it says “-bash: root@mineos: command not found”

If you receive an error, it will be important to know what you typed. The entirety of the message should be present. I don’t know what you typed.

I typed
root@mineos games/minecraft# netstat -tnl | grep 8443
tcp 0 0* LISTEN

Well, it looks like when you typed it this time, it worked.

This shows that the webui is up.

Where are you trying to connect to the webui from? From your phone, or a computer that is on your server’s network?

I’m trying to connect from a laptop that is on the servers network.

Actually, based on these specs, you really shouldn’t expect this to work well, anyway.

256MB is way too little memory, and it seems like that computer is effectively weaker than a raspberry pi.

I have run Minecraft servers on it before, the problem was I was using Windows XP which doesn’t support Java 8 which newer versions of Minecraft require.

If it doesn’t use too many resources, I can do it in a VM on my Dell Latitude D630, that thing is pretty powerful. It has a Core 2 Duo T7250 and 4GB of ram that can be upgraded to 8GB.

Well, I’m not saying you can’t run it, but it is the kind of thing I would expect to not run especially well, and at 256MB there’s quite a bit of that used by the webui itself (maybe about 90MB).

Usually 90MB is chump change to servers who operate on GBs, and the functionality is worth that hit, but 90MB is a small fraction of 4GB, but is like a third of your machine here.

Based on the fact that you’ll only be able to run one server on this machine (likely), it may be that you might not want a webui management system taking up the scarce resources.

Well how do I set up a server without the webui?

Realistically, the way any non-MineOS user does.

  • install some linux distro
  • install java
  • download mc server
  • java -jar minecraft_server.jar

Do you have any distros that you recommend for the p3 system? I can always go back to Windows, I’ll just be limited to what MC version.

How do I install java from a command line? Again, never used linux before this, always used Windows.

I googled and tried to install java using sudo apt-get install default-jdk but it just told me that sudo isn’t a command.