A funny thing happened on the way to my MineOS WebUI

Nope, no updates on commit or other changes than the ones i listed above to get it up and running. I did not run into the underscore error either (which is as it should, since underscore really should not matter, i have a few servers with underscore in the names that work fine).

I think this may be a virtual machine / VMware thing, since I had to tweak a few settings to get it running. The biggest difference is after all that I now run your VMware image in a virtualbox virtual machine (https://www.virtualbox.org/). Two different Virtual machines.

And the PAE-thing. I had lots of trouble with that one when I started.

This may be significant but unsure if it would be worth the effort to resolve. It would also be helpful if other VMware users were the ones reporting the ‘fireworm’ issue.

(It was as if the server was trying to write something, found it couln’t locate it and just gave up reporting some fireworm issue. Still unsure what program would generate that error, nice if it could be traced back to VMware.)

PAE-thing probably would have stumped me :wink:

Always a pleasure.


If you disable PAE/NX in your VM, do the error persist?

PAE/NX works by adding registers to 32bit memory handling so that it can adress a larger memory area than 4GB. (see: http://windows.microsoft.com/en-us/windows-8/what-is-pae-nx-sse2). It might be that the virtual host tries to write to PAE defined memory areas that do not exist.

With more time I will follow up, first blush I am not sure I have seen any PAE/NX/SSE2 and no win8.1.

There is a setting I use, it is thick provisioned, lazy provisioned and thin provisioned I thought they had to do with how it writes to the hard drive. I have been using thin provisioned as my SSD supports it, however since we are talking about write errors, I wonder?


Ignore the win 8.1; that is just who microsoft wrote that article for. IT is also the one where PAE is the easyest explained.

For moe PAE/NX is a setting I have to activate / deactivate in the settings of the virtual machines. If there is no easy way (or you cannot find where) to disable this, I could see if the version of your VM runnning here (with PAE disabled) runs better in your system. This off course would mean that I export my version, and make it available for you to download again.

Does the issue not exist if you update beyond this commit? Or is it not just replicatable? Is there an issue you’re experiencing more severe keeping you from wanting to update to recent commits?

Any amount over 4GB I think should necessitate PAE. There’s a real threshold when PAE becomes a must, but this shouldn’t affect the webui–it’ll be more at the “does Linux recognize my ram” level.

Connectivity to 8443 can be tested with this megathread I just wrote.

Honestly, I think all fireworm issues can be tied back to the Minecraft server-software itself or some latent bug from leftovers in the filesystem–I really cannot think of how the cause can come from lower-level than this.

Sorry I haven’t been able to address this so much–work has been pretty packed and I have a family vacation coming up until May. I’ll see if I can squeeze in an attempt with these HDD uploads.

As far as I understood it, this was only a necessety for 32-bit systems. PAE added 4 bits so that the adressing area was increased to 36-bit. 64bit systems do not have this memory limit as it has a far larger adress pool for memory. This shows itself in the way that any memory above the adressing area is not shown.

The trouble with the 32bit 4GB limit was that with 32 bit the entire system had a max of 4GB memory adress space available. This included space for processor cache and video card RAM.

So as long as he is running a 64 bit system, PAE should be unnescesary.
Example in hand:

I run my system without PAE/NX enabled, but with 16 GB memory. It is an ubuntu 64 bit server, and my MineOS happily repports all memory :slight_smile:

Webminstatus showing memory:

Virtaulbox Mineserv overview:

Yes indeed, PAE is required to add/enable for 32-bit systems because 32-bit couldn’t handle above 4gb. This is consistent with what you’re saying.

I’ve misspoken, though: PAE is necessary for many more systems than just 32-bit systems with more than 4GB of RAM. Many Linux distros (including what I believe is the case for 32-bit MineOS Turnkey using Wheezy) require PAE just outright, even if you don’t pass the memory threshold.

That said, I don’t think PAE should matter much in terms of getting MineOS up and running. Unless I’ve glossed over some really pertinent posts here, PAE should matter in pretty much two instances only: 1) did the system boot up without giving a PAE error? 2) did the system recognize and make available all the RAM expected?

And with 64 bit systems, as is this case and your own, PAE is irrelevant. Sorry for confusing contributions!

A lot to go through here, I will also need some time and have some coming very soon.(weekend).

Thanks all you guys.

Order of events:

Serve old .iso’s with out huge issues, small irritations mostly. (wheezy with java7)

Started to serve new .iso and began not reaching webiu. (jessie w/ java8).

Went back to wheezy, the commit was1853741 (Ithink and very stable) Decided to update java7 to java8 due to ‘other’ issues and began not to reach webui. Thought it was java related issue so did not report here and continued to troubleshoot. (Here is where the commit issue is, I had updated the webui to bcb4bd5? and did not notice.)

I would delete the troublesome servers and create new VM’s for frech installs, I noted at some point the commit moved past a previous commit to a new commit and the problem stopped. 2d22dc1, I think. I may have the sequence wrong, I assume you would know the order of commit updates.

so working with old .iso and update java 7 to java 8 i was able to replicate with commit 0e45bet, and noted if I updated the commit the problem would resolve.

At some point I was getting the same error with wheezy and java 7. That made me think it was a ‘commit’ error. If that was true where were all the others posting up suffering the same problem? Only me.

This made me think it was more a combination of things than only just one thing making trouble so I wanted to load the interim commits to confirm and found out I did not know how to do that.

Sorry for long winded answer.

Yep, and this is why I find it interesting to test wether tNt would have the same faults on his server if he deactivated PAE, since I now runs a duplicate of his server where the WebUI crashes on his VM, but stays stable at mine. The MineOS and turnkey installations are equal, with the only difference being Vmware ESXI 6 (with PAE, 2 networkscards and floppydrive)vs Virtualbox 4.3 (without PAE and floppy drive, and only one Network card). Since the differences in all practicality is virtual hardware, and it is stable on my platform and not his. I can’t imagine an empty virtual floppy drive, or a spare network card would have any effect. When I tried to run his VM with a pure import, it simply wouldn’t start up beyond the “loading ramdisk” message on boot.

One of the reasons I disabled it in the first place was that my Ubuntu Server installations ran (and booted) painfully slow. After googling a lot I found a post like this : PAE/NX, software virtualization, and Linux guest hangs in VirtualBox | Wilders Security Forums
I cannot any more find anything else to back up this claim though.

I am still trying to find that setting here.

Interesting here in that he is trying both vmware and virtual box with similar results as ours:


Checking this setting to see if relevant:

CPUID Mask Expose the Nx flag to guest or ( Hide the NX/DX flag to guest).

"CPU Identification Mask

Hiding the NX/XD flag will increase vMotion compatibility between hosts, at the cost of disabling certain CPU perfomance features for some guest operating systems and applications"

Thinking this might shut off (hide) PAE as well, need to confirm.

Yes, this would be worth a good try.

I need to find what format ( OVF or OVA ) would be best, I have had good luck importing .iso if that would work.


Link sent on PM.
No changes to user and password

Found it maybe.

" PAE also enables several advanced system and processor features, including hardware-enabled Data Execution Prevention (DEP), non-uniform memory access (NUMA), and the ability to add memory to a system while it is running (hot-add memory)."

IF DEP is enabled, PAE cannot be disabled. So have disable both DEP and PAE for windows machines.

VMware adds the ability to hot swap memory, to do this I think it turns on PAE, per above.

So If I turm off the memory hot swap option it might turn off PAE.

Still checking.

Could be boiling down to an ESXi issue as in another case of migrating VM’s. He can see PAE is on after migrating to ESX but can not when the VM is in ESXi.

" I moved this VM from ESXi into ESX, I was able to power back on the ESXi copy and there is no reference to PAE when it is running on my ESXi server. PAE only shows up on VMs running on my ESX servers and it is on every guest VM we are running is ESX, without exception it was VMs that were migrated over from ESXi, "

Is there some function for autmatically restarting the GUI? I am browsing through the log of my copy of @tNt’s server, and even though it seems everything is stable and up, I see several server starts in the mineos.log, and several instanses of the error we are hunting for. The only thing I really notice is that I occationally have to log back into the WebUI.

logfile: http://nik.melsom.be/tNt.mineos.log
(Everything from april 17. and before is tNt, all from april 19 and after is me)

You can test the WebUI at https://mineserv.no:8443 user and pass same as tNt gave further up in this thread.

It is at least an interesting quirk that I find the same errors, but that the WebUI seems to restart in stead of crashing…

Well, I just noticed was no longer available for the webmin service. Color me embarrassed for just now noticing, lol.

I think I used to have it on wheezy and on jessie it was closed.

I used it once or twice only and used webui on :8443 mostly. Planned on checking system information here like iMelson had posted.

I am thinking if i add 12321 to the iptables it will then become available.


You can’t reach webmin since it is no longer activated by default. This was a change in releases starting with jessie:

Thanks for that important info.

The correct permissions are 664.