Web page refreshes on login attempt {Fixed}

I installed MineOS without a problem on an old pc I had. Everything worked fine until I tried to log in through the web page. No matter what I type in the login box it will just refresh the page and nothing will happen. There is a similar problem in this thread here. I have tried resetting the WebGUI updating it and I’m am fairly new to Linux and MineOS so I didn’t really understand what was happening in that thread. Can anyone please help?

EDIT: I deleted the login.html so it was https://[myip]:8334/admin and it sent me straight to the dashboard. But nothing works.

The issue is likely that your distro is using yescrypt as the authentication method. This is what is used on the newest releases of distros.
The TKL release here has been modified (if I am not mistaken) to change it back to SHA512.
You can change it back to SHA512 and reset your password (theres a thread here or google your specific distro) and this should resolve the issue.

If I understood (I probs didn’t) are you saying that I should change the hash method to sha512 for the computer’s password?? I don’t know if this is anything but /etc/login.defs (or something like that) has the hash method or set to sha512.

Last I read it was /etc/pam.d/common
or something similar, change yescrypt to sha512 then issue a password change using sha512 (can’t remember the exact command)

Is it a specific command I need to run to or can I just change my password using passwd after changing yescrypt to sha512? I tried googling how to issue a password change using sha512 but nothing came up.

There was a command that wasn’t passwd. but if you restart and then passwd maybe it’ll work.


1 Like

Thanks that worked. I set it to sha512, changed my password, and rebooted.

1 Like