Upgrade Exisitng Server from profile 179 to 180


I am a bit bewildered as to how I can upgrade my kids existing server profile from 179 to 180. They have lots of work put into their existing world and naturally losing it would be the end of the world for them /sarcasm.

I have changed the profile under server.properties to 180 but that loses their buildings they have created.

I am using Mineos installed on Ubuntu 14.04 by the way.

Thanks in advance,


I just went through this. Did you create the 180 profile before trying to assign it to a server?

Submit it, then update it. Then try assigning the profile vanilla180 to one of your servers, or make a test server. When I first assigned it to one of my active servers it spawned the players WAY far away from their buildings, but they were there.

Please note, Minecraft 1.8 is a stock profile in the web-ui, which means it is available through the normal drop-down box on the profiles page.

It will, however, only be available if you have updated the web-ui since September 2, 2014 (the release date). I encourage admins to update regularly (via these git instructions) regardless of minecraft server jar updates, as often small changes are made to improve the user experience of the webui.

Check the wiki for detailed instructions on using git to update the webui.

As an aside, I can make no educated statements about how updating to 1.8 adjusts gameplay or player positions, etc. It is my understanding that all jar updates are intended as drop-in replacements, which mean that your server content should still be maintained, even if there is the inconvenience of being inadvertently relocated in-game.

Really? I didn’t know that. Maybe I should have tried updating the Web-ui.

So I was trying to update the web-ui and git merge would not run. So I ran 'git-clean -n -d" and here is the output:

root@core games/minecraft# git fetch
root@core games/minecraft# git-clean -n -d
Would remove LICENSE.md
Would remove README.md
Would remove README_ru.md
Would remove auth.py
Would remove auth.pyc
Would remove conf_reader.py
Would remove conf_reader.pyc
Would remove generate-sslcert.sh
Would remove html/
Would remove init/
Would remove mineos.conf
Would remove mineos.py
Would remove mineos.pyc
Would remove mineos_console.py
Would remove mounts.py
Would remove mounts.pyc
Would remove pam.py
Would remove procfs_reader.py
Would remove procfs_reader.pyc
Would remove server.py
Would remove stock_profiles.py
Would remove stock_profiles.pyc
Would remove tests/

Is this correct? Am I already at the latest version?

Where is git-clean coming from?

As the wikipage advises:

If updating the scripts returns an error or otherwise fails to solve a web-ui problem, you can try resetting the scripts.

So, put another way, if the following fails:

git merge origin/master

Instead try this:

git reset --hard origin/master
chmod +x server.py mineos_console.py

When I first ran git merge:

root@core games/minecraft# git merge origin/master
error: Untracked working tree file 'LICENSE.md' would be overwritten by merge.
fatal: read-tree failed

I tried to look up what that meant, and it was suggested to run git-clean to see what git says needs to delete.

So how do we upgrade an existing server then? Do we simply edit the server config to vanilla180 from vanilla179? Or do we just copy the vanilla180 jar file into the server folder?


Just edit the server config with the new profil :wink:

  1. update the webui…
  2. create a new profile using the new stock profile for 1.8.0 now available since you updated.
  3. change the profile to use vanilla180 on the server.config page

Looking up that error is a prudent thing to do, but the steps in the wiki took that into consideration when advising resetting the scripts should an error occur.

For a full technical explanation, read on:

When MineOS Turnkey is installed, it comes with an included copy of the scripts at /usr/games/minecraft. The script files here, however, do not constitute a fully initialized git repo.

Thus, if you were to SSH on a new install (or an old install that has never been updated), you’d see this:

root@core games/minecraft# git branch

root@core games/minecraft# git checkout
fatal: You are on a branch yet to be born
root@core games/minecraft# git checkout master
error: pathspec 'master' did not match any file(s) known to git.

So thus you git fetch (1st step of updating):

root@core games/minecraft# git fetch
remote: Counting objects: 2862, done.
remote: Compressing objects: 100% (58/58), done.
remote: Total 2862 (delta 53), reused 21 (delta 15)
Receiving objects: 100% (2862/2862), 4.45 MiB | 1.89 MiB/s, done.
Resolving deltas: 100% (1410/1410), done.
... omitted ...

And then after you try git merge, it gives the error you received (2nd step of updating):

root@core games/minecraft# git merge origin/master
error: Untracked working tree file 'LICENSE.md' would be overwritten by merge.
fatal: read-tree failed

Once you received that error, following the wiki, you reset the scripts (1st step of resetting):

root@core games/minecraft# git branch       #still not on a branch!

root@core games/minecraft# git reset --hard origin/master
HEAD is now at cfa2e56 added spectator gamemode to create server flow
root@core games/minecraft# git branch       #now you're on master!
* master

My issue is all fixed now. Not sure what fixed it but a few configs weren’t carried over in the upgrade.