This webpage is not available (ERR_CONNECTION_REFUSED)

I did a standard install on new hardware, from the Turnkey ISO. Everything went according to Will’s video. Got the IP address (10.0.0.240) using DHCP. Doing ifconfig shows a typical arrangement with the same IP address.

When I try to connect from another computer on the network, I get the connection refused message. The address bar shows http://10.0.0.240/admin. When I explicitly type https://10.0.0.240, it times out.

I am able to login to Webmin, for what it’s worth. When I try to SSH with the same password for root, it seems to think it’s the wrong password. Help!

Hi.
To accsess the webmanager of MineOS you need to add :8443 at the end of the URL. In your case:
https://10.0.0.240:8443

As for SSH into the server, you cannot use the root user as it is disabled by default. You need to log in with the local user you set up while installing Turnkey. If you used the vid this would probably be the “mc” user. You then use sudo to fire off root/administrator commands.

to activate the root user for login you need to do:
sudo passwd root

This will prompt you for a password for the root account. After thus you can use the command “su” to log in as root from the mc user.

http://minecraft.codeemo.com/mineoswiki/index.php?title=Root_login

Root login (but not the user itself) is disabled by default as a normal security convention. Typically, you shouldn’t need to log in as root, but there are cases. For the most part, mc is the user you’ll log in as, as it is the user who owns all the Minecraft servers you’ll be creating.

1 Like

I shoulda known that. All is currently awesome–thanks!