[SOLVED] WebUI crashes immediately

I just updated MineOS to the most recent version (as of 6 Jan 2020) using the standard script. I now have an issue where mineos crashes upon starting.
Running supervisorctl status mineos
mineos FATAL Exited too quickly (process log may have details).

supervisorctl start mineos
mineos: ERROR (abnormal termination)

function send_query_packet(port,host='localhost') {

SyntaxError: Unexpected token =
at exports.runInThisContext (vm.js:53:16)
at Module._compile (module.js:373:25)
at Object.Module._extensions..js (module.js:416:10)
at Module.load (module.js:343:32)
at Function.Module._load (module.js:300:12)
at Module.require (module.js:353:17)
at require (internal/module.js:12:17)
at Object.<anonymous> (/usr/games/minecraft/webui.js:3:14)
at Module._compile (module.js:409:26)
at Object.Module._extensions..js (module.js:416:10)

*Is there an anti-spam mechanism here? The ^ is pointing to the =

I can still access the machine through WinSCP and PuTTY, but webmin for some reason doesn’t appear to be online. When I try and access the WebUI I get a PR_END_OF_FILE_ERROR. Here is the last portion of mineos.log.
I have also tried the reset script as well as restarting the machine.

There was a recent commit to that line submitted by another user that helped solve a problem he had with multiple network interfaces.

In my testing I found did not cause any issues, on two of my test VMs.

But since you’re running into this issue, I’ve reverted that while I now try to figure out why it’s not working in case the affected userbase is even greater than those with network configs similar to yours.

#1 update to the most recent commit as of 1 minute ago, and this issue should be immediately resolved.

#2 I couldn’t see the mineos.log from your link to pastebin. I’m wondering if it’s a version issue of the dependencies. Did you update the webui with the update_webui.sh script, or something else?

If you’re able to provide that mineos.log again, it would be helpful.

Thankyou for that! Everything seems to be working alright now.
The pastebin was just the last, hopefully relevant section, but here’s the whole log: https://send.firefox.com/download/a2d3f82399750aaf/#GB6kvdM6j_U-XR5JhuIzNA
I used the convenience scripts, yes.