[SOLVED] Unable to setup external/remote access for WebUI


#1

The server is fully operational and works fine. I can connect to the webUI and client locally, and players from outside the network can also connect. I am using No-IP, a DNS service, to save me finding my IP every time someone want to connect.
I am moving away from the physical location of the server soon, and I want to access the WebUI remotely. I have tried port forwarding 8443 using all kinds of external ports, but nothing has worked. When I type in the url with the port I just get either no connection or my router login page (which also happens with no port specified). I have even tried 25565 as external port, which I know is forwarded successfully, but that still just gives me no connection.

Am I doing something wrong? Thanks in advance.


#2

Did you try DMZing the server if your router has the option? It worked for me.


#3

Doesn’t seem to have worked, even when substituting the internal port 25565 for 8443 on the external 25565.

The internal IP is most definitely right.


#4

You shouldn’t need to worry about the ports with DMZ. Huh.

It basically opens up all the ports on the target computer while keeping the rest of the network safe.

Can you show me how exactly you are accessing the web UI? URL mainly.


#5

External players connect through a DNS that I setup. I’ve been trying to connect to the UI using “https://domainname:port”


#6

Just to make sure you aren’t connected to your local network when trying to connect with the external IP right?


#7

I thought that wasn’t an issue as the external IP takes me to my router page by default.


#8

Try it I’m pretty sure it would work


#9

Hahaha just asked a friend and it connected without the need of DMZ. Silly me lol. Thanks for the help!


#10

Lol okay omae no baka