[SOLVED] Mixed Messages as to whether my server is up or not

Recently, for some unknown reason, my server stopped connecting to the network. I can’t connect to WebUI, WinSCP, or through the minecraft client (local connection and public connection). The weird thing is, going to https://dinnerbone.com/minecraft/tools/status/ and putting in the public connection shows it as being online. I have checked the port forwarding and it all seems to be okay.

Every so often I can connect through either Minecraft or the WebUI, but I am shortly cut off within about 15 seconds.

Any Ideas?

What do you mean by you are cut off from the web-ui?

Also, are you able to connect to the server through putty?

Lastly, when you say you “can’t connect”–do you get an error that demonstrates why you can’t?

Before I have chance to login I get ‘Unable to Connect’ window in Firefox. My connection to the network is still running fine at this point.

I managed to login via WinSCP, but opening a PuTTY session gives a window titled “PuTTY Fatal Error” with the description “Network error: Connection refused”. At the same time I logged in I tried connecting via the WebUI, it was successful and I could access the console and send commands, etc.
Trying PuTTY again, I was met with success, managed to login, but exactly 60 seconds afterwards got another Fatal Error, this time saying “Network error: Software caused connection abort”. At this point the WebUI threw up the “Server did not respond to request” error every time I tried to communicate with it.

Thank’s for your help!

Is this an install of MineOS turnkey? Is this another distro? Did this server ever work–or is this a recent occurrence?

Is it always 60 seconds?

If this is a new install, I’d recommend reinstalling.

If this is an old install I’d recommend removing MineOS and seeing whether wins poor putty still systematically fail.

This sort of erratic behavior, not localized to one service but simultaneously to ssh, http, 25565 minecraft… Seems to suggest network issues. Or something being terribly wrong with the install somehow.

Sorry, I should have given that information in the original post. This is an install of MineOS turnkey, installed November last year. I am not sure if it’s always 60 seconds.
If you think it is a network problem, I would think it would be my router setup, which has the tendency to be rather obnoxious. I will try and tinker with that as I can, and post back here if I get any results.

Thanks for your assistance.

Hrm, if the server has been going for 4+ months–and nothing else has changed–that’s quite perplexing indeed. Network seems to me the most likely culprit based on the erratic disconnections you’re receiving (rather than failure to connect), but I’m wondering if there are any things you could’ve configured that would’ve caused this issue.

I’ll keep on poking around and mulling it over.

Have you restarted the server? As in the machine not just minecraft server. Does the issue persist immediately or does it return after some time?

The entire machine is turned off nightly as it’s just a little project I did for my friends. And yes, it does persist,

I do believe I’ve solved it. Manually attaching a screen and keyboard, I logged in and changed to DHCP connection. It then gave me a one digit different IP address. I then changed back to static with the new address, and rebooted.
All seems to be working fine now.


1 Like

If you can log in the your router you can assign that as a static lease and it’ll never move.