[SOLVED] Can't Set Static IP Address

Hey all,

I am getting back into MC server administration and decided to give MineOS an install again. Last time I used MineOS was when the CRUX distribution, I configured that and had it working just fine. Has not been so easy this time. Problem is… I am unable to configure or connect with my network. I have done some googling already and am pretty much having the exact same issue as this person.

http://www.turnkeylinux.org/forum/support/20140315/default-route-not-saved-when-configuring-static-ip

I have a Dell 2950 Power Edge server with two NIC’s. I first used ConfConsole to set a static IP on my network. Everything took except for my default gateway. It says none and when I go back to edit it, within ConfConsole, it is blank. Same thing no matter how many times I set it or which NIC I use.

When I check ect/network/interfaces it displays correctly, see below. However, I cannot ping anything on my network from my Turnkey server and vice versa. I tried changing which NIC has the static set, setting a static on both NIC’s, and setting both/one to DHCP. When DHCP is enabled it says…

udhcp (v1.20.2) started
SIOCSIFFLAGS: No such file or directory
Sending discover…
udhcp: sendto: Network is down
Read error: Network is down, reopning socket
Sending discover…
udhcp: sendto: Network is down
Read error: Network is down, reopning socket
Sending discover…
udhcp: sendto: Network is down
Read error: Network is down, reopning socket
/etc/udhcp/default.script: Lease failed:
No lease, failing

I am able to ping the static address on the server and it will reply back. When I run ifup eth0 it returns RTNETLINK answers: File exists Failed to bring up eth0.

I found a post before saying that drivers might be the issue, however, it is detecing both interfaces. I can reinstall them but have never done that before.

UNCONFIGURED INTERFACES
remove the above line if you edit this file

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.0.7
netmask 255.255.255.0
gateway 192.168.0.1
dns-nameservers 8.8.8.8

auto eth1
iface eth1 inet dhcp
Thank you for looking.

Annnnnd I was able to find a fix.

http://www.turnkeylinux.org/forum/support/20130618/getting-no-network-adapters-detected

I used wheezy firmware and it is working now.

Phew :slight_smile:

2 Likes

Had the same problem and this was the fix!
Thank you!!!