[SOLVED] [Bypassed] Restart not working


#1

Im using MineOS Node. Everything’s working fine except the scheduled restart.
If I manually stop and then start it again, everything works just fine, also scheduled simple say command and that works fine too.

But when the restart event is started, server shuts down and never starts again until I start it manually.

In older MineOS there was a commit delay which i increased and then it all worked, but where can I find this in Node?

Also, how do I format the title command to get it working?
Bonus question too. Is text coloring possible in any of the textbased commands?

Thanks for this wonderful software! It’s awesome!


#2

Does /var/log/mineos.log show any errors?

When ‘restart’ is scheduled, it waits up to 30 seconds for the stop to queue up the start action. If the server shutdown takes longer than that, it would explain why the restart fails. If the shutdown is taking less than 30 seconds though, that behavior is bugged.

What kind of server type is it? (profile)
From the same logs (or the webui), what commit version are you using?


#3

Errorlog -> https://pastebin.com/6YNkx99X

Running FTB Beyond 1.10

git commit: 2a85c26


#4

You mention that the scheduled restart does not work. Does a manual restart work?

If a manual restart works, so should the scheduled, but even if it doesn’t it is also possible you can do this instead:

scheduled stop
scheduled start one minute later.

A commit delay? I’m not sure where that would factor in to stopping the server, but if it’s just terminology we’re not matching up on, the delay that mineos will wait before it errors out in stopping is 30 seconds.

Not from the webui.


So, 1) does manual restart work.
2) does scheduled stop and scheduled start work?


#5
  1. Yes, i did that in first post too, works flawlessly.
  2. Be damned, made 2 cron schedules in webui, start and stop with a couple of minutes apart. Works just nicely!

Any other examples on how we can use /title?

Thanks!