Server stops and won't restart

I am running a standard vanilla 1.8.3 server, turn key Linux x64, and randomly the server stops running, No one can connect. Overviewer is still running, I can access the webui and I can console in. under the webui it says the server is offline, if I press start it says start success, but it stays in offline mode if I then press stop it says the server must be running to preform this action. I can press start multiple times and it keeps telling me success without doing anything. the only way I can fix it is if I restart the whole physical server, it will then run about 12 hours before it locks up again.

Please Help

Why the server crashes is something I can’t know–but you’ll want to check your server logs for any indication of what happened. It could be something like out of memory or it could be corruption in the world files.

At any rate, when it’s crashed–rather than hit ‘start’ again, you can try this instead from the console to see whats going on. Try the following commands as the user mc.


This will allow you to see if the java process is still running.

cd /usr/games/minecraft
./ -s servername screen

This should attach you to the running screen process, if it is. Then, you can look at the output and determine the cause of the crash, and perhaps why the server is still a running process, but isn’t recognized as so in the webui.

I don’t see anything in the server logs, they just stop with no indication that the server stopped.

When I run “top” I see that java is not running. So I started thinking java was crashing. I realized that I had screwed up the java_xms value and was running out of memory. It looks to be overviewer is eating up all the ram by not stopping. Now I have to figure out why it is eating up the ram… time to search a new forum…

Not sure why but after I run the second line(./ -s servername screen) I get a permission denied. I also did a su but I am still getting the permission denied.

Thank you so much hexparrot!

Ah, yes, I also entirely overlooked that possibility, but Overviewer is notorious for memory consumption!

I think though, Overviewer actually has a ram limiting argument I’ve seen before, too…