Remote access issues


#1

I installed mineOS a couple weeks ago and once i had it up and going i have not had an issue. I an running a forge server for 1.7.10 for 5 people. and thats it. My friend was not allowed to enter the server because the game would always crash whenever he tried to log in and in the crash report it said it was a “ticking error” so after research we found out what he was the ticking error. so accessed the game files with winSCP which i know works fine because thats what i used to install the mods, and i deleted his profile from the world directory in hoped it would reset him and i would just spawn in his inventory. but after i did that i can no longer remote access the server via the webUI winSCP ot puTTY. The server starts up fine and loads directly to the screen where it says the servers IP and Port etc. The server is set up to start on boot and does not start up at all. what can I do if anything? Am I just going to have to reinstall mineOS which isnt a problem if I do. If I do have to reinstall mineOS can i get the world back in any way, yesi do have the restore points and archives saved via the webUI


#2

Can you describe better the actions you took that immediately led to everything not working? We’re you doing stuff as root?

Try the command history to find out what was specifically done.

How do you know it didn’t start up? Because you can’t connect to it, or because you’ve seen the process up and alive via top?

Have to, no. Pretty few circumstances (barring just deleting system files recklessly) would warrant a full install. That’s not to say it’s not the easiest way to get back up and running, but we don’t have enough information on what you did or what’s wrong to be able to tell.

If you want the quickest return to uptime, a reinstall would be fastest, but you’d have to do that after getting your archives put in a safe place…which you may not be able to do.


From the console (the actual keyboard/monitor for your server), see if you can ping google.com, that’ll tell us a bit about your internet connectivity. Did you change anything regarding your networking settings? Do you know if you’re using DHCP or a static IP address? Perhaps everything is up but the IP address changed?


#3

All i did was delete his player files in the world directory.

I am unable to connect to it via the game.

I a unable to access the server to ping google. I can not access the gae via the webUI, puTTY, WindSCP, or Minecraft itself.

I accessed the game files with winSCP to delete his player files in hope it would just reset his character. And the IP is static i even made sure to check. When i turn the system on the only way i can access it is is when i connect a video output to it and i get the splash screen where it tells me the IP (which is how i know it has not changed)


#4

I also did NOT modify the OS in any way just his player files.


#5

Why can you not ping google by accessing the server via the normal video output of the server?

Right now, everything that’s occurring seems to point to a connectivity issue on the OS side–not a Minecraft/MineOS thing.

In other words, sure, you may have the IP address set static, but if networking is somehow still not working, Minecraft, MineOS, SSH, SFTP–all of those would not be expected to work either.


#6

sorry for the really last response but the issue fixed itself