Problems with web UI

I have been experiencing two separate but possibly linked issues for a while now with the web client. when i attempt to connect to the web client i am met with a security error pointing to bat certs. i attempted to fix this by following the instructions on this page but the instructions are a little vague ant to be honest above my level, after acknowledging this message and continuing i can log in and do what i need to do, the second problem comes in where after a seemingly random amount of time information stops updating in the webui and it stops accepting commands and button presses. the solution is to reload the page which brings me back to the first error then gets me to log in again, i don’t know if this is caused by some kind of auto timeout gone bad or directly caused by the cert issue but i will be in the middle of doing something, not even afk, and it will just stop accepting input, i can still go between tab and click on things but any actual command such as starting or stopping a server or typing in the console just does nothing until i refresh, accept the auth warning and log back in.

troubleshooting steps so far,
i attempted the auth update but clearly did not do it right as i am still having issues
i updated the server and related things using apt upgrade

EDIT: when the issue occurs the TOP command indicates that node is using 120-220% cpu ussage and varies wildly

Do any of your servers do any dynamic mapping, e.g., dynmap?

Are any of your server directories extraordinarily large (larger than a few gb or tens of thousands of files?)

i do have one server that uses a dymap style map, however the files are hosted in a separate file tree away from the mineos files. i have a total of 5 servers (not all running at once) taking up 12gb. the high resource usage that i spoke of earlier i seem to have fixed by resetting the webui to default as per this guide. however the other issues remain. let me know if you need any logs or anything

This one is easy’:
Just ignore it.

It is an internet certificate error stating that there is no known certificate (or no known verfified internationally certificate) to your LAN only server address (or if you are accessing it externally: matching both your DNS host name and local server name). This is of absolutely no risk or consequence. It simply says that it expected a cert that said “yourhost.yourdomain.somewere” to be equal to the adress given to you generid local host name when you access a local address. Getting rid of this error requires you to learn how to manage certificates on internet linux server…

still doesn’t explain the second part of the issue

For the second problem the sympoms points to the Mineos WebUI crashing and automatically restarting. This would invalidate your login, and force you to log back in when you reload.

As to why it crashes? No idea. @hexparrot tried a guess at a map making utility, but that is the problem. We can only guess at things that have caused problems before. Other culprits may be some of the following:

  • Memory / Resource issues
  • certain flavours of pockemtmine casue MineOS crashes,
  • FTB-style servers (or rather some or a combination of the mods they use))are prone to go bad and crash mineos
  • Some buckit plugins have caused crashes

Without more information (like the MineOS logs) we cannot really help.