"onreboot start" not working


I just installed MineOS on Ubuntu in VMware, but sadly the Server does not start automatically. MineOS does, but not the MC-Server. “onreboot start” is checked. Already tried the rc.local fix found on groups.google, but with no sucess.
Can anybody help me?


First, check the logs for any errors: /var/logs/mineos.log

Secondly, can you confirm the servers start up without issue when attempted manually (from the web-ui with the ‘start’ button?)

Can you link the rc.local fix you made? I’m not sure what it recommended, but I’d like to verify it should have applied to your system. For the most part, ever since I released instructions for “MineOS-on-Ubuntu”, I feel like there’s been little to no need to make adjustments from the initscripts. I’m most concerned if they were instructions for the previous 0.5.x UI. I’m worried that you might have been following instructions written before there was an authoritative tutorial.

Lastly, how did you install MineOS? The installer script? Manually? Have you gotten a server to successfully start thus far? Let me know any details you find pertinent and we can go from there.

EDIT: /var/logs/, not /var/log typo


everything else works. I can start, stop, backup and join servers.

I installed MineOS using the apt-get Method on the Wiki:
Because auto-starting the server didn’t worked I searched google and found this:


Because it didn’t work with this either, i already removed those entries in rc.local.

And it seems as if the mineos.log does not exist. If I try to open it with nano, I get an empty page:

I have the same issue. onreboot doesn’t work.
I did a manual install on ubuntu following your directions. I can start and stop the server fine from the webui.

my mineos.log

[20/Sep/2014:14:17:03] ENGINE Bus STARTING
[20/Sep/2014:14:17:03] ENGINE Forking once.
[20/Sep/2014:14:17:03] ENGINE Forking twice.
[20/Sep/2014:14:17:03] ENGINE Daemonized to PID: 1279
[20/Sep/2014:14:17:03] ENGINE Started monitor thread 'Autoreloader'.
[20/Sep/2014:14:17:03] ENGINE Started monitor thread '_TimeoutMonitor'.
[20/Sep/2014:14:17:03] ENGINE Started monitor thread 'Monitor'.
[20/Sep/2014:14:17:03] ENGINE PID 1279 written to '/var/run/mineos.pid'.
[20/Sep/2014:14:17:03] ENGINE Serving on
[20/Sep/2014:14:17:03] ENGINE Bus STARTED
[20/Sep/2014:14:20:14] ENGINE socket.error 1
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py", l$
  File "/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py", l$
  File "/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py", l$
    success = self.read_request_line()
  File "/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py", l$
    request_line = self.rfile.readline()
  File "/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py", l$
    data = self.rfile.readline(256)
  File "/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py", l$
    data = self.recv(self._rbufsize)
  File "/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py", l$
    data = self._sock.recv(size)
  File "/usr/lib/python2.7/ssl.py", line 341, in recv
    return self.read(buflen)
  File "/usr/lib/python2.7/ssl.py", line 260, in read
    return self._sslobj.read(len)
SSLError: [Errno 1] _ssl.c:1429: error:14094418:SSL routines:SSL3_READ_BYTES:tl$

[20/Sep/2014:14:20:18] ENGINE Started monitor thread 'Session cleanup'.

Perhaps you have the same [situation I had][1]?

If the Server-IP property is set, it may inhibit the server from automatically starting on reboot. Strange as it is, it worked on Ubuntu for me, but not on Arch.
[1]: http://discourse.codeemo.com/t/demi-solved-servers-fail-to-bind-to-port

It’s not set for me.

I am still unable to reproduce this issue; servers start for me as expected.

The best I can come up with at this point is permissions–can you confirm your servers are recursively owned by the appropriate user (likely ‘mc’)?

It seems to me that anytime the web-ui can start/stop a server, so should the initscripts, as they invoke the same function ‘start’…

It’s /var/log/mineos.log, not /var/logs/mineos.log. And BTW, why not to use Midnight Commander?

I have run sudo /etc/init.d/minecraft start
which works as expected, strange that it doesn’t auto start.

Adding sudo /etc/init.d/minecraft start
to rc.local works but it is a pudge.

1 Like

I once had that issue with my restarts. Ran into it when I rebooted my (Hardware-)Server on a schedule.
Servers wouldn’t start on boot.
For me it got solved by introducing a and raising delay between boot of mineOS and the actual Server startup routine.
Seemed like a racing condition somewhere.

sudo crontab -e

then add the following to the bottom line

@reboot sudo sudo /etc/init.d/minecraft start

Just created an account to say that this worked for me when I was having a problem getting my server to start on boot. Thanks!

I’m running the MineOS Webui on Elementary OS(ubuntu-based)