NPM deprecated errors

I got these errors when updating the Web-UI:

Script execution started on: Sat Sep 3 17:53:59 CEST 2016 Updating mineos-node repository...OK Checking out master branch...Already on 'master' OK Resetting directory to official contents...OK Deleting npm module dependencies and rebuilding...npm WARN engine apache-crypt@1.1.2: wanted: {"node":">=5"} (current: {"node":"4.5.0","npm":"2.15.9"}) npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130 npm WARN deprecated to-iso-string@0.0.2: to-iso-string has been deprecated, use @segment/to-iso-string instead. npm WARN deprecated jade@0.26.3: Jade has been renamed to pug, please install the latest version of pug instead of jade npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue OK Setting node javascript files to executable...OK Script execution ended on: Sat Sep 3 17:54:52 CEST 2016

Dear DIY_glenn,

these are not errors.

these are warnings and have no ill affect on MineOS.

as far as i know, (AFAIK) MineOS is optimized for node 4 and do not recommend to use node 5.

best regards,

tNt

1 Like