Mineos WebUI says no servers exist but server is up

#1

I tried adding a data pack to my server and it caused all the servers to disappear on the web ui. However the servers still exist and can be joined. Does anyone know how to fix this? Thanks!
(im running mineos on freenas)

#2

Based on your description, the data pack you added made the server no longer respond to normal “ping” queries. So, yes, the servers are still up, but now MineOS has no idea how to work with it.

What pack did you add that broke it?

#3

I’ve found that MineOS frequently fails to list all of the servers I have on my machine, showing just the first one in my case. I then have to go up to the “mc” menu in the upper right and click that, revealing the option “refresh server list.” Once I choose refresh, then the screen is redrawn and all of my servers show up. When this happens, it’s generally the first time I log into the app, but it doesn’t happen every time I log in. It’s kind of random when it occurs.

I think that the installation of the data pack might have been incidental, and not necessarily a cause of the problem. It’s just a glitch in the way the app fetches the server names or something.

Tommy, could you try to use the menu item “refresh server list” to see if the app grabs all your servers correctly?

… if this is still an issue for you…