Minecraft PE server: RedstoneLamp (and some Pocketmine)

The last official beta og version of Pocketmine is way back in version 1.4.1, while the latest blleding edge earlier than alpha use at own risk version (I have downloaded) is PocketMine-MP version 1.6dev-37 "[REDACTED] (and trust me, as Mojang and MS pushes out updates, it is getting hard to keep up on the edge (for the very latest in all Pocketmine versions go here: http://jenkins.pocketmine.net/). There is a very distinct lack of features…). As much as I lift my hat to the PocketMine crew, it seems that their development is lagging behind.

since I still haven’t found the “perfect” P.E. edition server software, I still occationally hunt for other servers. Today I found Redstonelamp (http://redstonelampmc.com/). I tried just downloading their jarfile to see if it would play nice with MineOS, but no such luck…:frowning:

MineOS throws me this error (from logs):
{“level”:“info”,“message”:"[PE_Test] issued command : “start”",“timestamp”:“2015-12-24T09:39:14.358Z”}
{“level”:“info”,“message”:"[PE_Test] received request “start”",“timestamp”:“2015-12-24T09:39:14.358Z”}
{“command”:“start”,“uuid”:“31ab2d60-aa22-11e5-856d-dd74d43097c6”,“time_initiated”:1450949954358,“success”:false,“err”:“XMS heapsize must be positive integer where XMX >= XMS > 0”,“time_resolved”:145$

-Xmx and -Xms is both filled, I have tried variables from 256 MB to 2048 MB. (It’s a test server, just testing to see if I get it to start for now, so memory use is of no matter to me yet).

I have traced this error down to a mismatch in current and required Java versions. (My current: 1.7.0_79, required for Resstonelamp: 1.8 and above. Is there any problems forMineOS in upgrading Java to 1.8?

Has anyone else tried experimenting with Redstonelamp? Anyone got it working through MineOS? It seems like they are making it to be standalone.

Alright, there are two things to point out here:

  1. The error isn’t indicating that memory allocations are the problem, rather than Java. It’s saying that you’ve not made the XMX value greater or equal to the XMS value. Perhaps you have them reversed?
  2. MineOS is a front-end. It’ll use whichever java is in your $PATH variable. You can replace Java with any version you want…MineOS will use it.

What have you filled, specifically, in for your XMX and XMS values?

First of a litte “D’oH!”

The XMX/XMS-issue: I mixed those two up. Sorry about that. I fixed that up, and that error disapeared.
It still won’t start up though, but as it is a test I’ll look into that later. I’ll keep you posted.

Thank you for your help.

(I am now using this as some kind of log to document what I do to get Redstonelamp to work in MineOS, in case someone else wants to run it…)

After updating javaI got the Redstonelamp instanse up and running. I had to symlink the redstonelamp log to get MineOS to read it (It uses Reddstonelamp.log as logfile, symlinked it to latest.log (ln Redstonelamp.log loatest.log) and it showed up like it should).

Right about now I have connection issues. The server is up and running, but I cannot connect through Internet (using port forwaring in my router). Still investigating this though, and have to test some more when I get home, and can test over lan.(shouldn’t be any limits, since I accept all connections in on my MineOS server, and I set up proper port forwarding on my gateway. )

1 Like

So, after an hour more testing I have arrived at a conclution that the MCPC (minecraft for PC) part of Redstonelamp is broken. It is stuck on an earlier test release of Minecraft 1.8 (Minecraft version 15w35e). The latest release do not accept connections, when activating it Minecraft can’t get past pinging it inthe server list. going back to a earlier more stable release do not allow a 1.8x client connection. By allowing testbuilds of minecraft I can download 15w35e and connect, but thisdidn’t work properly.

I havent tested the MCPE part yet, since I need my win10 machine at home to do this.

Redstonelamp is an interesting prosject though, as it seems it bundles both an MCPC and an MCPE server in one, and (as also our esteemed developer and admin here already has stadet several times in several threads) MineOS accept any minecraft server jar, as long as we set everything up correctly. I’ll keep you posted on further tests and developments :slight_smile:

I have testet the MCPE-part of Redstonelamp as well now (on win10PE, android and iOS), and the current version is (at least for me, or rather my nephews and niece) a no-go. The version it uses serverside is too old for the current client.

My current conclusion is that once java is updated to the required version or above there should be no problem running Redstonelamp on MineOS. The current version is not running server versions that is comptaible with current versions of MCPC (1.8.9) or MCPE (1.13.1). This is an interesting project, so I’ll definately keep my eye on it, but for now it is wrong for my servers.

Oh, and it seems like Redstonelamp died: