Infinity / web UI, bit confused


So I have installed infinity evolved as root and created a server. When I start the server the web UI, shows the normal up status, but when a client connects, the server shows a down status in gray with a check mark next to it and the client reports that the server is still starting, oddly it also still continues to broadcast its presence to LAN.

There are no entries in the error log either. Has anyone come across this?


For starters, you shouldn’t ever create servers as root, but instead as “unprivileged” users (non-root) that are appropriately protected from damaging effects on the server.

Without letting a client connect, can you verify that the server actually remains up or if it actually goes down on it’s own.

Are you checking the box that says “broadcast to LAN”? This is a MineOS function and not a Minecraft function.

Finally, there was a known issue with infinity, specifically, because infinity–unlike almost every other profile, seems to operate differently than every other feed the beast jarfile. See this git issue:

Can you confirm this issue exists with any other profile, or is it exclusively Infinity causing this problem.

Do you use a none standard port for you server?
If so, it could be a firewall(iptables) parameter setup thats missing?

Apologies, have been away for a few days.

Still unsure what the issue was, but I reinstalled Java via command line within mineOS, rebooted and it started working.

I’m not overly fussed on security, the machine has limited access and I just use it as a creative server locally to test builds before building them on my main hosted server.

Hmm, so I updated the server to the latest version and the problem cropped up again. I manually started the server and was met with the following:

A problem occurred running the Server launcher.[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:478]: java.lang.reflect.InvocationTargetException
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:481]: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:481]: at sun.reflect.NativeMethodAccessorImpl.invoke(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:481]: at sun.reflect.DelegatingMethodAccessorImpl.invoke(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:481]: at java.lang.reflect.Method.invoke(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:481]: at
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTrace:481]: at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTraceAsCause:505]: Caused by: cpw.mods.fml.relauncher.FMLSecurityManager$ExitTrappedException
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTraceAsCause:507]: at cpw.mods.fml.relauncher.FMLSecurityManager.checkPermission(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTraceAsCause:507]: at java.lang.SecurityManager.checkExit(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTraceAsCause:507]: at java.lang.Runtime.exit(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTraceAsCause:507]: at java.lang.System.exit(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTraceAsCause:507]: at net.minecraft.launchwrapper.Launch.launch(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTraceAsCause:507]: at net.minecraft.launchwrapper.Launch.main(
[23:12:59] [main/INFO] [STDERR]: [java.lang.Throwable:printStackTraceAsCause:509]: … 6 more

Not really sure what to do next.

My best guess is you’re telling the webui to run either a) the wrong jar file or b) with the wrong arguments.

Launchers are not used in a server, command-line interface; they depend on GUIs.

Unfortunately not. With the WebUI, I’m running the latest .jar and, well there are no Java arguments, The only thing that is set is the heap size at 2 gig, and I have tried increasing it, but no joy.

In the crash log it registers as an Exception in Server Tick Loop error.

This gives me no actual, verifiable information you’re actually running the correct jar, though.

As mentioned, the latest FTB .jar :

FTBServer-1.7.10-1558.jar under the FTBInfinity-2.3.5 Profile. I’ve run the via command line. No Java Arguments, Heapsize set to 2048. The result is the above issue and error in the crash log.

I made sure everything is up to date, including the recent node.js release.

So wiped the machine completely and tried again, unfortunately the same issue came up. Vanilla Minecraft runs fine, but Infinity and Direwolf come up with the same type of errors.

Next I just installed Debian and manually downloaded and installed a server - pain to admin without a back end, but it worked fine, so I can only conclude there is either a turnkey issue, or an issue with MineOS itself.

Best guess is that you have permissions issues (did you perhaps do anything, such as run the scripts for FTB as root?).

You can verify this with:

ls -la /var/games/minecraft/servers/[myservername]

If you have accidentally did those previous tasks as root, then the files it downloaded/generated are owned by root, which would also explain why the webui (which doesn’t start servers as root) cannot start a server.