High RAM usage & GUI unresponsive on v. 1.17

Hi All

My mineOS was running perfect but after the upgrade to v1.17 I now see memory usage close to 16G RAM and the UI GUI says the server is down (But its running)

I really don’t want to do a new install, is there any way to find out and stop any tasks?

I am running MineOS on Unraid as a docker:

I cant even get the version…
I found another docker that might be more updated.
Would I be able to just copy the server DIR to the new MineOS?
And start the server again?
Or would this require import of a archieve to work?

You can use the backups or transfer the archive file, then import it on the other system, if I’m reading your request correctly.

Thanks @fornaxbeowulf But I don’t have a backup or a archive file
The server is running on a older MineOS docker and when I login to the webui I cant controll
anything, but the server is running with +16G ram load - I think its the Dynmaps maybee if I delete the dynmap I can get back to using the UI and create a archive for restore on the new docker?

BUT - isnt it just possible just to copy the server dir to the new docker without the Dynmaps folder and start it up? (Copying files for 24 hours now and all the files is located on a fast NVMe SSD to NVMe and still it takes forever so many files)

@fornaxbeowulf I tried different browser and I got the UI working in firefox (I did delete the dynmap folder) and I now have a new archive file. I then copied that to the new docker in the import folder.
(I did change the properties and the archive ie showing with correct name and size)

But after selecting it and writing a new server name I cant start it?
Also server name is not visible in dropdown?

I am beginning to think that the two MineOS dockers is using different Java versions and that might be why I cant import my archive? - cant see java version in the MineOS WEBUI…

To answer your question, yes, I believe you could copy the sever directory over, but I haven’t tested it.
The only other thing I could suggest with the WebUI is to make sure the commit version is current.

To anyone who finds this post:

  1. Create a new server on the MineOS using the same name (no spaces)
  2. Start the server see its running (Same Java and profile 1.17 etc)
  3. Check that the Mineos is running with the same Java version old docker was 16 new one was 8 (I could change that in the docker settings: binhex-mineos-node docker)
  4. Stop the server and copy the world subfolder from your old server and make sure properties is correct owner ets… nobody/users
  5. Start the server and see its running
  6. Stop it and copy all plugins with settings and start it again
  7. Now you can change your server to something else! I tried PaperMC and it runs much faster!
    Done everything is working and memory usage is much lover and UI very responsive