Feed the beast server refuses to start

I have to say I love the user interface. Unfortunately I run into a bit of a snag starting feed these servers. I download the profile then create the server. Click copy over files from profile from feed the beast. I set the Java arguments for RAM and runnable jar. Then I click start server and accept user agreement. Nothing happens. Then I try to click on the start server and nothing happens. Anyway there’s no feedback from the user interface whether or not the servers even tried to start.

Browsing the mineOS.log nothing stands out as an issue. A vanilla server starts as expected.
At first I thought it might be something wrong with actual mod pack but it runs fine on a different PC.

As a side note once I get this figured out I’m using the mod pack as a base for my own pack. That being said is okay to add files to existing profile such as feed the beast?

this is a comon issue that is very easy to fix.
you need to either at the server keyboard or from an SSH terminal goto /var/games/minecraft/profiles/FTBPROFILE

and run the following command

sh FTBInstall.sh

this downloads the server jar which is not allowed to be packaged with the ftb pack. from then on any server made with that profile will work perfectly. additionally in this same location you can edit the eula.txt file and change it to true and you never get the prompt on any new servers for the eula.

1 Like

Thanks for the help! I feel bit foolish.

Hey to piggyback.

I have a few FTB profiles that will never start. I have not been able to figure out why. I tried the sh FTBInstall.sh and get a access denied error.

access denied might mean the FTBInstall.sh is not given executable permissions. Two options:

chmod +x FTBInstall.sh before you run it.
sh FTBInstall.sh

i usually just run the install as root with
sudo sh FTBInstall.sh
then everything works as normal.

Doing server-specific things as root is how permission problems eventually surface. Because then all the files that FTBInstall.sh creates are owned by root:root, in a directory owned and otherwise operated with mc:mc (or other non-root user).