Crontab Scheduler not wanting to work. What do I have to do?

#1

I’m running PaperMC 1.14.4 on MineOS Node (commit b28c5be) on FreeNAS 11.2-U5.

Quick back story in case it matters: I’ve been running a PaperMC 1.14.4 server on a web host for a couple months now. It’s all worked flawlessly so I just copied the entire server folder and plopped it into MineOS. The server seems to run as-is with no issues aside from backend stuff like crons and restarting.

Now my issue: The Scheduling tab has a lot of weird things going on. I’ll add a cron task to the list but it doesn’t show up until I refresh the page. Then the ‘Suspend’ button will be grayed out and active, with the ‘Start’ and ‘Delete’ buttons bright and ready to be pressed. When I press Start nothing happens even after refresh. I can go into the cron.config file and change ‘enabled=false’ to ‘enabled=true’ which will gray out the ‘Start’ button successfully but the task never seems to run. Sometimes after editing cron.config the whole WebUI crashes and can’t be reached until I restart MineOS completely. I’ve tried the default commands of Start, Stop and Restart and even tried ‘Send to console’. Nothing happens for any of them.

What the heck do I have to do to run a Cron job here? Thanks for any help!

#2

As a disclaimer, I don’t have direct experience with your configuration, so this is just shooting from the hip, but…

Are your files’ owners, groups and permissions all happy? MineOS uses the mc user and I’m not sure what a straight file copy would do. The Web UI might not be able to show errors of that nature in a tidy fashion. Just a thought, or maybe this suggestion will inspire a different solution.

#3

Thanks for the reply. I’m too dumb to figure all this stuff out I guess. I don’t even know where to begin to troubleshoot this outside of the WebUI. I don’t know what the owners/groups/permissions would be.

And now it won’t load my servers in the WebUI so I can’t even try to see if anything works. :man_facepalming: