Change or remove timeout session

Let me explain, when I’m on the webui for MineOS I like to see the cpu usage and look at the three servers I’m running and see if there are issues but when I leave the page it “freezes” and I need to refresh the page and log back in.

Is there a way to either increase the wait time or remove it altogether?

I have MineOS installed under Ubuntu Server as I found using Tunkey is a bit of a hassle when I need to update the OS itself with security patches or add additional software. IDK if that makes a difference or not.

Freezing isn’t a normal behavior. You should normally be able to keep the webui session open…for like, a long long long time. Longer than you’d probably spend in any given administration/play session combined.

So freezing is happening because of something else, can you share your /var/log/mineos.log?

It’s perfectly good for you to use the underlying OS of your choice, but Turnkey is Debian, which is what Ubuntu is based off of. Can you elaborate in which ways Turnkey made it more of a hassle than it’s sibling Ubuntu?

Here’s my log: https://paste.ee/p/QyiJn

For using Turnkey, I ran into issues trying to update java to a more recent version and trying to change the default version would not work for me.
Adding other software/sources like a hardware monitor to allow me to see temps/disk usage and network usage from a remote connection kept failing to install when it was a Debian package.
I also had an issue trying to mount my flash drive for copying the server files when FTP wasn’t working and for whatever reason it kept mounting it as RO but would not let me access it at all.
In my 5 years of using Linux, never had this many issues where I could not work it out. I mostly use "sysable"buntu for my linux needs but I experimented in using Arch and I enjoyed that. Backtrack (before it was renamed Kali) and Puppy Linux for some under powered devices I have.

I’m just glad that there was a git install for MineOS.

Here’s a video showing my issue. https://youtu.be/soLy_V1EMB8

If you would like the full log, let me know as it’s 6mb.

Update to my issue.

It would seam that if I have more then 3 servers running at once it happens. Especially if I’m going between them watching the log files.

Question, can you verify it really happens after starting a fourth server? Or can it stop operating properly at the 1st, 2nd, or 3rd, because it’s server-specific?

I can easily get the webui to handle (just now) 6 vanilla servers.

I imagine if I have a nonvanilla server that didn’t work with the webui for some reason, it might feel l should be able to reproduce this freezing before the 4th server.

At any rate, I’ve never had access to a server that ever froze the webui, so one day, when somebody can provide such a reproducible case, I can probably figure out the underlying code issue. But until then, I keep rehashing the same speculation that it’s server-specific, not server-count related.

Of course, and I meant when I have 3 running not 4. Sorry for the confusion.

I specifically have 4 servers but I only run 3 at a time.
1.7.10 has about ~130 mods
1.12.2 has ~120 mods
RL Craft has ~120 mods
1.14.4 has ~80 mods

I mainly have the 1.12.2, RL and 1.14 running. I only run 1.7.10 when I want to go back to before certain things changed mod wise or weren’t ported to a newer Minecraft.

And as of typing this, the MineOS site has stopped responding with only have 2 servers running (1.7.10 and RL Craft).

Edit 1: So after starting a 3rd server (1.14.4) it froze again so I refreshed the page and logged back in and I just watched the load averages and it froze after 38 seconds of watching it and doing nothing.

Edit 2: It would seam that having RL Craft running breaks it. @hexparrot

If you’re able to share this world–likely just the files for the server+plugins, and not the whole world–if I’m able to reproduce the webui stopping working, I can fix it.

Here you go: https://drive.google.com/open?id=13IqhS46A-7L3E-j0d5FE02QJMDPZyA2q

Specifically it’s a Forge server 1.12.2.

I’ve had the webui open and it has not frozen but the moment I run that server, it breaks.

-server -XX:+UnlockExperimentalVMOptions -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=3 -XX:NewRatio=3 -XX:SurvivorRatio=3 -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=8 -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:+ExplicitGCInvokesConcurrent -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60 -XX:+BindGCTaskThreadsToCPUs -Xnoclassgc -XX:UseSSE=4

6144 and 4096 are my ram and jvm args is posted above.

Side note, are you familiar with what these flags actually do?

-XX:G1NewSizePercent=20 -XX:G1ReservePercent=20

This is for the G1C1 collector.

XX:+UseConcMarkSweepGC XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60

This is for the separate, Concurrent Mark Sweep collector.

Only one collector runs, but you have arguments that are modifying two separate ones.

Well I run that same flag set on all my servers and don’t run into any lag or stuttering, I was told that the G1C1 works more on the young generation and the concurrent works on the old generation.

Was I misinformed?

Also if you can’t recreate it on your end, PM me and I’ll give you my ip and login info as I have the server at my work place as I have it port forwarded.

Can’t reproduce. Running 4 vanilla servers and your RLcraft and it works as expected. I can definitely try your own server.

That said, I think I have an idea of why that might be the case. Might be I never actually have to deal with enormous servers (in aggregate) so it’s hard for me to reproduce because we’re running into a race condition…

Try changing the check interval:

On this line, it’s 5000. Change it to 12000. That’s 5 seconds to 12 seconds. I’m wondering if this could help allow each heartbeat enough time to work, on heavily used/high activity servers…

I’ll give that a shot and I’ll send you my info.