Cannot connect to MineOS Web

Hey again, I’m having more problems.

My friend cannot connect to my MineOS Server. I have the 3 major ports forwarded, but he still cannot connect. I can connect however. Could I please get anyone’s help?!? Thanks

-SteveTheKid

If you’re able to connect from your own desktop (that is not the server machine), then the issue lies squarely in one of two places:

  1. port forwarding configuration
  2. the ports you have chosen are blocked by your ISP.

Google a port checker and see if the 3 open ports you have opened are detected by a port checking website…if they cannot be seen, it will return the same result as your friend gets (no connection).

Any chance that you are giving me the wrong external IP?

Try using http://www.whatismyip.com/ or something.

No, it’s the right IP

I still can not connect, let’s wait for someone with more knowledge to help us out here.

Maybe ask the ISP for help about IP addresses and ports.

@NLGAMER1000, and @SteveTheKid, this is what you need to look into.

Are the ports open with the port checker?

You are running two computers with MineOS right?

Guys, could that be the problem?

Steve, ask your router manufacturer and isp for help

Hi SteveTheKid! How are you? Have you been able to solve your issue?

If you not, can you please post your network configuration and topology? eg.:

Public Internet (provider) > Modem (brand+model+version) > Wireless Router (brand + model + version) > Server bare metal (type+nic model) > operating system (mineos turnkey or other -please specify)

Please use the same syntax for the other computers trying to connect (and / or connecting) to the server.

Excuse me for my english, i’m from Argentina and maybe i’m missing some grammar =)

Regards,
J.

Hey everyone,

I googled a port checker

canyouseeme.org

And all ports were open.

I have the network set up as follows

Internet Modem (Ubee Cable Modem)
Dell Optiplex GX620 (Ports: 25565, 8080, 22, 20 all ports that are major)
Straight through

UPDATE: The modem that I was using completely went haywire, and we had to replace it. There’s still a Ubee modem, just a different model # (I do not know what it is)

I should be able to get it working.

@Brian_Lowery I have used this internet connection before, so I know that the ports aren’t “closed.” I have talked with the ISP (Time Warner Cable) and they said that they could not connect, and that it may be the modem. Turns out that is what it is but I cannot seem to get the ports to work right. I’ll eventually figure it out, but I was already a step ahead of you. =)

Hello Steve

I tried some port checkers and they still see the ports as closed.

Could you put some addresses here for people to try and connect?

Niels

If you’d like I could assist you remotely using team viewer

I can ping your IP with CMD, Steve, I tried some website port checkers and Putty on a few ports that should have been opened by you, they are NOT open.

Usually pinging is never forwarded, and as a result, most of the times you ping it’s an ICMP packet that is reaching the modem/router itself, and not the server. If none of the other ports are responding, this seems like the same issue mentioned before: port forwarding is done incompletely/incorrectly or the ports attempted are being blocked an ISP.

1 Like

He can connect to the web interface locally but he says that no outside connections are possible. He claims that this is because of a faulty NIC buildin ethernet card, is this possible?

And could it be fixed by putting an seperated Ethernet card into the computer?

If one can connect locally, I’d say there’s no chance it is a faulty Ethernet card.

One additional way to test is to have his windows machine (presumably his desktop) host Minecraft on 25565 (or some other port).

If he can connect to that server from outside his network, he will have demonstrated he knows how to turn on port forwarding. If he can’t, either its a port forwarding issue or port blocked. Blocking is less likely on 25565 though, unlike FTP or HTTP ports, so it would suggest pebcak.

To further narrow it down, he could make the server hosting minecraft “DMZ” (temporarily). So, his Windows machine if he’s testing that or making his Linux machine DMZ. The DMZ setting is a router setting, not a computer setting. If he can connect now, then we know it was failure to set up port forwarding correctly. If not, it pretty much leaves ISP blocking and … (DMZ setup pebcak).

Hello again, It has been awhile, and I still cannot get it to connect outside. I have actually tried to connect with @NLGAMER1000 on my teamviewer, and it will not connect. Now, I have changed computers with two Lenovo ThinkCentre m70e small form factor computers, versus dell optiplex gx620 computers. I still have problems. It isn’t anything wrong with the network, cause I have pinged a computer on the same network, and, it worked. @ElPres If you can on here, PM me and I will give you my teamviewer connection details. Anyways, the IP’s are:

192.168.192.1
192.168.192.2

Both seem to be unresponsive.

Again, I did have local connectivity, but, no outside connectivity.

-SteveTheKid

Steve:

The IP’s you are giving are your local IP’s and will not help us in helping you.

are you certain you have port forwarded 25565 to the 192.168.192.X machine that is your server? not your client?

Lee

I just got back on here, those are the local ip addresses that I connect to. I cannot disclose my external ip for the fear that someone browsing on here grabs it and tries to DDoS me. I still have problems after trying multiple things. I tried reinstalling the drivers and it does not work. I do not know what is going on. I’ll keep trying new ideas as they come in, if anyone has new ideas as to what we can do to squash this bug.

If you can successfully connect locally, there is no reason to suspect the drivers or the webui service. If you can connect locally, and not remotely, its a port-forwarding issue or a your-isp-is-blocking-the-port-issue. Firewall is a possibility, but MineOS Turnkey doesn’t come with it blocking anything (and other distros typically do not block anything out-of-box either).