1.12 Server Not Working in FreeNAS

When I tried to upgrade my server from 1.11.2 to 1.12 on MineOS for FreeNAS, the server would not start at all. To try and troubleshoot, I attempted to create a new server on MineOS that ran 1.12. It would also not start. No error messages would display, the server would simply not start.

In order to make sure nothing was wrong with my current install of MineOS, I completely erased my MineOS jail and re-installed MineOS through the FreeNAS “Plugins” menu. The result is the same. Upon clicking the green start button, nothing would happen, and MineOS gave me no indication of any error.

In addition, if i try to import a .zip server file and run it on MineOS via version 1.12, MineOS will begin crashing and will not properly turn on until I delete it and re-install it! Very frustrating.

Does anyone know what is going on? From browsing around on the net, do not think this is an isolated issue! Thank you for any help.

Have you read a few posts down in the forum? Since 1.12 came out this has been asked repeatedly. But I’ll behave:

It is due to Minecraft 1.12 needing Java 1.8. So have you updated your MineOS installation with java 1.8? Please do a search in this forum (or simply scroll down the list to one of theother FreeNas MineOS threads about this) to read what has been discussed, and has been done to resolve this.

I had this exact issue. try pkg install openjdk8 and see if that works. I’m a FreeNAS noob but that’s what worked for me.

Would you mind posting a screenshot how and where exactly you applied that code to?

Trying to understand what people keep telling me to do I tried it in FreeNAS > Jails > mineos_1 > Shell but it just won’t let me start a 1.12 Server.

root@mineos_1:/ # java -version                                                 
openjdk version "1.8.0_131"                                                     
OpenJDK Runtime Environment (build 1.8.0_131-b11)                               
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

Is there another setting you applied elsewhere to get yours running?
Maybe something inside the MineOS browser window?

That’s exactly where I did it, in the Jail shell. And you do have the correct version, which I also ran into this issue. What I ended up doing was deleting the plugin and jail, and redoing both (It was my first time using mineos so I didn’t have any servers made already), but idk if that is an option for you. But redoing them ended up working for me… You can also possibly try pkg upgrade openjdk7 and I believe that will try to update the java version that your mineos is currently trying to use. That’s all the info I got though sadly, hope it works for you.

Strangely enough I managed to get it to run 1.12 but what exactly made that possible will probably remain a mystery to me. Just reinstalling the Plugin was apparently not enough so I kept messing around when suddenly it worked.

For one, the Jail still only has an openjdk7 folder, no openjdk8 - Ah well… Beggars can’t be choosers I guess. For as long as it works I probably shouldn’t care ;]

Yeah basically same thing that happened to me… I reinstalled then did a bunch of random stuff and boom it worked. No idea what actually fixed the issue

I have been able to get my server running by entering the following into the jail’s command line:

service mineos onestop

pkg install -y npm
sed -i ‘’ -e ‘s|^(command=").*(")$|\1/usr/local/bin/node\2|’ /usr/local/etc/rc.d/mineos
sed -i ‘’ -e ‘s|^(start_precmd=").*(")$|\1export PATH=$PATH:/usr/local/bin:/usr/pbi/mineos-amd64/bin\2|’ /usr/local/etc/rc.d/mineos
sed -i ‘’ -e ‘s|^([[:space:]])/./npm([[:space:]].*)$|\1CXX=c++ /usr/local/bin/npm\2|’ /usr/local/etc/rc.d/mineos

service mineos oneupdate
service mineos start

pkg install -y openjdk8

The link below is my source for the code. Thanks to Joshua Parker Ruehlig for the information!

This has worked for me in both FreeNAS 9 and FreeNAS 11. Hope it helps!

I also installed 7 on Freenas 11 u2 and it worked for me:
pkg install openjdk7

I never make accounts or post things, but you guys just saved the day! thanks so much. I will note, in case anyone else is as big a noob as myself, that when they say to open the shell prompt “in the jail” they want you to go to the jails tab, select the mineos jail, and click the black shell button on the bottom. i tried clicking the shell button on the side panel three times…i guess i forgot how jails work for a minute (or 15). Anywho, thanks so much and have. a great week!

You can also use “jls” and “jexec [jail number]” to enter into the jail from your command line. If you are using a SSH client such as putty, you can then copy and paste code straight into the command line.